CleanupTemp n'existe plus.
[GroupUserFolder.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=4
10
11
12
13 build: DH_OPTIONS=
14 build: build-stamp
15 build-stamp:
16 dh_testdir
17
18 touch build-stamp
19
20 clean:
21 dh_testdir
22 dh_testroot
23 rm -f build-stamp configure-stamp
24 rm -rf build
25 rm -rf debian/python?.?-tmp*
26 dh_clean
27
28 install: DH_OPTIONS=
29 install: build
30 dh_testdir
31 dh_testroot
32 dh_clean -k
33 dh_installdirs
34
35 find . -type f -not \( -path '*/debian/*' -or -name 'build-stamp' -or -name 'LICENSE.txt' -or -name '.cvsignore' \) -exec install -D --mode=644 {} debian/zope-groupuserfolder/usr/lib/zope/lib/python/Products/GroupUserFolder/{} \;
36
37
38
39
40
41 # Build architecture-independent files here.
42 binary-indep: DH_OPTIONS=-i
43 binary-indep: build install
44 dh_testdir
45 dh_testroot
46 dh_install
47
48
49
50
51 gzip -9 -c ChangeLog > changelog.gz
52 dh_installdocs -A TODO changelog.gz
53 dh_installchangelogs
54
55 dh_link
56 dh_compress
57 dh_fixperms
58 dh_installdeb
59 dh_gencontrol
60 dh_md5sums
61 dh_builddeb
62
63 # Build architecture-dependent files here.
64 binary-arch: DH_OPTIONS=-a
65 binary-arch: build install
66 dh_testdir
67 dh_testroot
68 dh_install
69
70
71
72
73 gzip -9 -c ChangeLog > changelog.gz
74 dh_installdocs -A TODO changelog.gz
75 dh_installchangelogs
76
77 dh_strip
78 dh_link
79 dh_compress
80 dh_fixperms
81 dh_installdeb
82 dh_shlibdeps
83 dh_gencontrol
84 dh_md5sums
85 dh_builddeb
86
87 binary: binary-indep
88 .PHONY: build clean binary-arch binary-indep binary
89